From: Eric Friedman (ebf_at_[hidden])
Date: 2003-11-04 22:02:04
I've made several related changes to variant:
1) changed the name of boost::empty to boost::blank;
2) eliminated the variant<> syntax; and
3) changed variant::empty() to always return false.
These changes were motivated chiefly by a desire on my part to avoid
breaking interface changes in future Boost releases.
Specifically, in the next release "truly empty" variants may become
possible. In such an event, it would seem important to distinguish such
variants from variants with content of what is now called boost::blank.
Regardless, I find the new behavior clearer all around.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk