Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2003-11-14 08:47:53

Daniel Frey <daniel.frey_at_[hidden]> writes:

> wrote:
>> I think these are more descriptive:
>> prevent_unused_variable_warning
>> avoid_unused_variable_warning
> I like those, especially the last.
>> Or short and sweet:
>> use_variable
> No! use_variable(x) tells me that x is used for something, so I will
> wonder what that "something" is. I also like Brian's idea:
> boost::avoid_warning::unused_variable(x);
> as to me, it would make sense if we would have other stuff to put into
> boost::avoid_warning. (And maybe avoid_warning also help to avoid the
> concerns of disable_warning that Rene raised)

This feels like premature generalization to me.
I don't think we should establish a new namespace until we can
envision at least one other thing we'd really want to put there.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at