Boost logo

Boost :

From: John Torjo (john.lists_at_[hidden])
Date: 2003-11-20 19:11:24

>>The idea I am pushing for here is that ranges ARE NOT pairs of iterators.
>>Rather, a pair of iterators happens to make a good representation of a
>>range, but may not be the only one.
> Yes, I heartily agree.
> (As I said in a previous post) I think the fundamentals of a range support
> should facilitate the following:
> some_range_type r(. . .);
> for(; r; ++r)
> {
> *r; // Do something with the current position
> }
> This is very general, and therefore very powerful.

You're starting to win me over ;)

However, as said in my other posts, I just see a more "pure" range coming out.

We'll distinguish between traveral_range, and crange/irange classes as they are
now. So, I think crange/irange are fine as are, but we need a more "pure" class,
which will be traversal_range.


Boost list run by bdawes at, gregod at, cpdaniel at, john at