Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2003-12-12 10:29:03

"Olden A (Comp)" <aolden_at_[hidden]> writes:

> Dave/Edwards,
> Thanks for your help, I think the problem has solved - in the end it was
> actually to do with the set PATH/%PATH% problem rather than with the lib
> path,

What was the problem with the set command?

> when I tried to do the second command that dave suggested it failed because
> there was a space in between -L and the lib path - to stop a typo creeping
> in I just cut and pasted it so

No words in the line below make sense to me. Can you explain? Does
"fell over" mean "wrapped to the next line?" What is "the thingy?"

> it fell over - but for a different reason than the thingy.

> I took the set path command out of the Borland-tools.jam file and it works
> okay - the set command was causing it to exit the Borland-build-action
> before it was getting to the link action bit.
> Thanks both for you help, and sorry for being a stupid monkey.

You weren't stupid but we need to fix borland-tools.jam somehow and
removing the set path command doesn't seem to be the right approach.
We need to know more about what was wrong with that command.

> -----Original Message-----
> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]]
> On Behalf Of Edward Diener
> Sent: 12 December 2003 13:34
> To: boost_at_[hidden]
> Subject: [boost] Re: Re: bjam failure with borland 6 under xp
> Olden A (Comp) wrote:
>> <snip>
>> Ahh, I get two problem, Firstly when it tries to set the path it
>> fails, doesn't seem to like the %PATH%, at the end - I'm 100% sure
>> this is a problem with my system - after I tried what you suggestesd
>> I decided to try vsvars32 - the %PATH% on the end causes the system
>> to fail there too. The directory is in my path thought - I Have
>> confirmed this.
>> When I use the command:
>> "C:\Program Files\Borland\CBuilder6\bin\bcc32" -v -q -v -tWR -tWD
>> -WM- -L "C:\Program Files\Borland\CBuilder6\lib"
>> -e"libs\regex\build\bin\boost_regex.dll\borland\debug\runtime-link-dynamic
> \b
>> oost_regex_debug.dll"
> @"libs\regex\build\bin\boost_regex.dll\borland\debug\runtime-link-dynamic\bo
>> ost_regex_debug.CMD"
>> The system reports that it cannot find the file:
>> Error E2194: Could not find file 'C:\Program
>> Files\Borland\CBuilder6\lib.cpp'
>> I've done a search and I don't have a lib file in that dir - I have
>> one in the boost directory "C:\baysian\boost-1.30.2\boost\lib.cpp", -
>> Is this related?
> I think you must put the library path immediately after the -L option, so
> that in your command line you have:
> -L"C:\Program Files\Borland\CBuilder6\lib"
> _______________________________________________
> Unsubscribe & other changes:
> _______________________________________________
> Unsubscribe & other changes:

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at