Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2003-12-19 12:55:26

> Thorsten Ottosen <nesotto_at_[hidden]> wrote in message
> > "Fernando Cacciola" <fernando_cacciola_at_[hidden]> wrote in message
> > > > can "nearbyint()" be renamed to nearby_int() ?
> > > "nearbyint" is the name of a C99 function.
> >
> > so ? :-) just because C99 is hard to read it does not mean your code
> > to be. In the string lib, Pavol
> > consistently avoided this.
> Good point... but consider that most probably, "nearbyint" will be as
usual as "scanf" in the
> future, so familiarity will be important.

For me familiarity is in the name, not how the name is written with
concatenations or uppercase etc.
And so I prefer readability, but that's just my opinion.

> In the particular case of the RawConverterPolicy the whole
conversion_traits is passed in order
> to allow the policy implementation to _efficiently_ use all the
definitions there.
> An instance of "conversion_traits" passed to a policiy is a complete type
which means that all
> metacode was exceuted already.
> If each policy were to use separated traits, such as
"argument_type_of<S>::type" then a lot of
> meta-code will be duplicated and "meta-executed" again and again;
> All of the stuff defined in the conversion_traits is needed by the
converter so it is already
> "pre-meta-compiled" and can be readibly used by the policies.

sounds like you're right. I should be careful with such statements :-) I
wonder if there are any
general guidelines for this that have actually been tested?



Boost list run by bdawes at, gregod at, cpdaniel at, john at