Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2004-01-21 10:50:04

Bronek Kozicki wrote:
> I think that it is more generic, than having two classes move_ptr and
> move_arr; isn't it ?

No, it isn't more generic, since you can't really do generic (T-independent)
things with a move_ptr<T> if you don't know whether T is an array. But I've
learned to love the move_ptr<T[]> syntax.

Boost list run by bdawes at, gregod at, cpdaniel at, john at