Boost logo

Boost :

From: Angus Leeming (angus.leeming_at_[hidden])
Date: 2004-02-11 16:32:55

David Abrahams wrote:
>> In the section "Template Arguments for iterator_facade" is the
>> subsection "CategoryOrTraversal". I suspect that should be
>> "CategoryOfTraversal" (s/Or/Of/).
>> The iterator_adapter docs spell it "CategoryOrTraversal" too.
> No, the spelling is as intended.
> It's either an iterator category tag (such as
> std::random_access_iterator_tag) or an iterator traversal tag (such
> as boost::random_access_traversal_tag).

Thanks for the explanation.

Would it not be worthwhile putting something like this in the
documentation? Perhaps in iterator_facade.html#tutorial-example where
the CategoryOrTraversal template parameter is explained and where the
explanation mentions 'iterator tranversal concepts' only. Indeed
clicking on the link of that name takes me to a point where the
tables again mention only traversal.

Back to reading the docs.

Kind regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at