Boost logo

Boost :

From: David Bergman (davidb_at_[hidden])
Date: 2004-02-21 12:42:10

Daniel wrote:

> Douglas Gregor wrote:
> > On Saturday 21 February 2004 04:59 am, Aleksey Gurtovoy wrote:
> >
> >>We can (re-)consider 'boost::meta':
> >>
> >> meta::if_<...>
> >> meta::find<>
> >> meta::vector<>
> >> meta::set<>
> >> meta::map<>
> >> ...
> >>
> >>
> >>Doesn't look bad at all, actually.
> >
> >
> > I'm a big fan of using "meta" instead of "mpl".
> FWIW, I'm not. I type it often enough to be bothered by the
> completely unnecessary extra character.

You are kidding, right? One extra character... :-)

I do not like "meta," because it is actually more general (I almost said
"more generic"...) then "meta programs using templates for dealing with type
manipulation (and simple arithmetics,) executed at compile-time" which is
what MPL is all about, and for some reason "meta programming" have become
synonymous with that kind of manipulation in the modern C++ world. "Meta,"
on the other hand, can (still) denote "logic or data reasoning about or
representing logic or structures," such as in "meta data" for

In my opinion, the most correct, albeit lengthy, notation would be


Boost list run by bdawes at, gregod at, cpdaniel at, john at