From: Jonathan Turkanis (technews_at_[hidden])
Date: 2004-02-21 12:30:34
"Daniel Wallin" <dalwan01_at_[hidden]> wrote in message
> Douglas Gregor wrote:
> > On Saturday 21 February 2004 04:59 am, Aleksey Gurtovoy wrote:
> >>We can (re-)consider 'boost::meta':
> >> meta::if_<...>
> >> meta::find<>
> >> meta::vector<>
> >> meta::set<>
> >> meta::map<>
> >> ...
> >>Doesn't look bad at all, actually.
> > I'm a big fan of using "meta" instead of "mpl".
> FWIW, I'm not. I type it often enough to be bothered by the
> completely unnecessary extra character.
I like "meta"..
If you're bothered by the extra character, how about just "mp"? After
all, if it's part of boost, of course it must be a "library". On
second though, it must involve "programming", too, so why not just
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk