From: Powell, Gary (powellg_at_[hidden])
Date: 2004-02-23 21:21:19
I'm siding with Dave A and the longer names. You can always shorten it in your code with an alias.
For me it's a matter of future expansion, and maintenance, we have boost::bind, and boost::lambda::bind, and perhaps soon boost:fcpp::lambda which is the namespace which the function? If we use apprev. 4 everythg, thn, we lose contx.
boost::fs =? "FileSystem", "FastSort", "FirstSearch", "FloatingSymbols".... yes these are a bit contrived but you can usually use "using namespace", or a namespace alias safely within a function scope. Then when you leave the company the next poor maintainer of your code has a chance.
Also a global search is easier if the letters to be searched for are more or less a unique set.
From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of Beman Dawes
Sent: Monday, February 23, 2004 11:44 AM
To: Boost mailing list
Subject: Re: [boost] Re: algorithms namespace
At 03:28 PM 2/18/2004, Peter Dimov wrote:
>> I think it's a fuzzy line in the sand, so all I really know is that I
>> like "ref" and don't like "fs" :)
>Yes, is seems that it comes down to personal preference. Dave likes to
>filesystem, and you don't like fs...
I never liked either. "filesystem" is too long and sounds affected. "fs" is
too short and non-specific. Those names just escaped because nothing better
Maybe if the LWG likes the library enough to standardize it we can come up
with a better name.
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk