Boost logo

Boost :

From: Bjorn.Karlsson_at_[hidden]
Date: 2004-02-25 07:59:12

> From: Thorsten Ottosen [mailto:nesotto_at_[hidden]]

> > * Some names work "best" in plural (like signals,
> type_traits, iterators,
> > operators); this is of course very much IMHO.
> are they the names of namespaces?

Signals is (and type_traits has such a namespace [albeit only in detail]),
the others are the library names (living in the root boost:: namespace).
> > * Just "file" seems a bit restrictive to me, but when I
> think about the
> > namespace "files" I read "files 'n other related stuff, too".
> then maybe it should be namespace io? Just like a big namespace for
> algorithms, io
> could hold file handling, zip streams, formatters etc.

Yes, that's definitely an interesting option.


Boost list run by bdawes at, gregod at, cpdaniel at, john at