Boost logo

Boost :

From: Dave Gomboc (dave_at_[hidden])
Date: 2004-03-01 21:59:27

> > A list type is already present in ::std, and means something
> > different. Perhaps lazy_list, or (cringe) llist.
> Disagree. MPL has list and vector. I'd hate to see it named
> it differently. mpl::slist (static-list)? Yuck!

Hmm. To what extent does MPL get away with that because of the
compile-time vs. run-time distinction?

Incidentally, slist is taken already (SGI's singly-linked list) --
evidence that lazy_list is better than llist. ;-)

I guess I was thinking that if a lazy list ever made it into the
standard library, it would need a different name than list anyway.

Anyway, I'll cut this short -- can't spend all my time in the bicycle


Boost list run by bdawes at, gregod at, cpdaniel at, john at