Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2004-03-03 14:45:05

David Turner wrote:
>> Have you considered the 'on_delete', 'on_change' naming
>> scheme for signals (events)? It seems more GUI/RAD-like.
> Yes, but I think I'd rather name it after what it is (delete_signal)
> than after when it happens (on_delete).

Well, the assumption is that we all will know that on_* is a signal, so
there'd be no need to explicitly tag it as one. 'on_click' and 'on_change'
seem more natural to me compared to 'clicked_signal' and 'changed_signal',
and the on_* naming seems more consistent. It's a minor point, of course.

Boost list run by bdawes at, gregod at, cpdaniel at, john at