Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2004-03-25 19:09:13


I was hoping I'd be able to fix this once and be done with it, but alas
it is not to be. I need to change my fix.

The problem has been noted here already in the thread "std_min/std_max
reference return value is problematic with boost::interval." Basically,
the std_min/std_max helpers cannot be made to work on old compilers that
cannot detect reference returns.

I have to rip out std_min and std_max. If you want to make an
unqualified call to min or max, the recommended way will be as follows:

using std::min;
min BOOST_PREVENT_MACRO_SUBSTITUTION ( a, b );

I have 2 questions:
1) Is this the best name for the macro? Perhaps people would prefer
something shorter. I'm open to suggestions.

2) Is there anyone who wants me to hold off until they finish making
some big check-in to avoid merge hell? If so, please contact me
privately and we'll work out a schedule.

Thanks.

-- 
Eric Niebler
Boost Consulting
www.boost-consulting.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk