Boost logo

Boost :

From: Arkadiy Vertleyb (vertleyb_at_[hidden])
Date: 2004-03-30 21:33:46

Hi Joaquin,

>* Have you looked at mpl_index_list? This facility was
>designed with RTL in mind so as to ease the internal
>creation of indexed_set instantiations. Useful for your
>particular needs?

I am glad that you have this capability. It will definitely be very useful
for RTL.

However (and I know that many people on this list will disagree with me), I
don't see much benefit in wrapping MPL sequence in the first place.
Basically you just hide the MPL functionality, which you then restore with
the mpl_index_list, at the expence of two intermediate templates (one to
hide, and another to restore). And the more templates you have -- the
slower compilation is, and the closer are your users (especially ones using
VC6) to various compiler limitations, such as ISO, etc.

If you don't want you users to see MPL, I would just derive your index_list
from an MPL container, thus retaining all MPL container features, and
allowing other users to use MPL sequences directly.

>I'd appreciate if you take a
>look at the [naming scheme] proposal and either accept it or provide
>strong argument against it (or against parts of it)

While voting for your library with my both hands, with no regards which
naming scheme would be chosen, I still think that the name
"composite_container" is rather boring :(... I actually liked the
IndexedSet better. But since it is probably not a very "strong argument",
you can disregard it :)


Boost list run by bdawes at, gregod at, cpdaniel at, john at