Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-04-11 19:01:40


"JOAQUIN LOPEZ MU?Z" <joaquin_at_[hidden]> wrote in message
news:31c83531e9c8.31e9c831c835_at_tid.es...
>
>namespace boost{
> namespace multi_index{
> template<...>
> class indexed_container;
> }
> using multi_index::indexed_container;
>}

I think multi_indexed_container (or multi_index_container) would be a
better name. A long name doesn't hurt here since
the container will take some lines to setup with typedef etc anyway.

Then the class could be in the boost namespace and there could be a
helper namespace, index, which stored the index_list, unique etc.

This would make the setup of the container look quite good IMO:

typedef multi_indexed_container<
  employee,
  index::index_list<
    index::ordered_unique<index::identity<employee> >,
    index::ordered_non_unique<index::member<employee,int,&employee:age> >,
    index::sequenced<>
>
> employee_set;

Before I wasn't sure where member, identity etc came from.

br

Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk