Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-04-14 09:02:19

"Jeff Garland" <jeff_at_[hidden]> writes:

> On Wed, 14 Apr 2004 13:04:34 +0100, Val Samko wrote
>> JG> This email thread seems to be writing the repsonse to the FAQ:
>> JG> Q: Why is there no add_month function in the library?
>> JG> A: Because we can't agree on what it means...
>> Does that mean that add_month won't be implemented? What if we call
> It's a few lines of code -- so I think I'll still put it in :-)
>> it inc_month, instead of add_month? inc_month (Increase Month)
>> in no way assumes that the day of the month will stay the same,
>> it will just increase the month.
> Yes, perhaps a different name would help eliminate any confusion that we are
> doing 'math' here.

I think readability is more important. Nobody but pedants have
problems with string + string. Likewise I think:

         d + 2*months

or whatever is better than the functional-looking alternatives.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at