From: David Abrahams (dave_at_[hidden])
Date: 2004-04-14 09:52:49
"Neal D. Becker" <ndbecker2_at_[hidden]> writes:
> Here is an update to cycle_iterator. This is based on the original design
> by Gennadiy Rozental. After fairly extensive performance testing I am
> getting good results (compared to my old implementation which was
> hand-written, not based on boost iterators), after adding operator.
... which got poor results? Just wondering.
BTW, not to keep nitpicking but I object to the name cycle_facade.
iterator_facade really is just a facade for iterators, but
cycle_facade is a full-fledged iterator and should be called
-- Dave Abrahams Boost Consulting http://www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk