Boost logo

Boost :

From: JOAQUIN LOPEZ MU?Z (joaquin_at_[hidden])
Date: 2004-04-15 15:29:19

----- Mensaje original -----
De: David Abrahams <dave_at_[hidden]>
Fecha: Jueves, Abril 15, 2004 6:21 pm
Asunto: [boost] Re: [indexed_set] revised naming proposal

> Joaquín Mª López Muñoz <joaquin_at_[hidden]> writes:
> >> > If I decided to rename index_list as indices: what
> >> > would be your proposal for mpl_index_list?
> >>
> >> 'indexed_by_list<>' ?
> >>
> >
> > Well, this is less satisfying, I'd rather "mpl" appear in the
> name. What
> > about "mpl_indexed_by"?
> Oof. What does this MPL stand for??

Apart from index_list, there is an alternative
construct called mpl_index_list such that,
for example:

mpl_index_list<mpl::vector<K1,...,Kn> >

is equivalent to


mpl_index_list is provided as a convenience for
MPL metaprograms synthezising instantiations of
indexed_set. "mpl_indexed_by" is a possible renaming
for "mpl_index_list" should we decide to rename
"index_list" as "indexed_by". Suggestions for
better names?

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at