From: Peter Dimov (pdimov_at_[hidden])
Date: 2004-05-06 07:53:14
Thorsten Ottosen wrote:
> Let's assume this library is to be called Range Traits with
> RangeConcept, ExternalRangeConcept and,
> ExternalReversibleRangeConcept, can John/Mathew then find a
> reasonable name for their concept:
> crange<T> r = make_range( vector );
> while( r )
> ++r; *r;
> could they call their stuff TraversableRangeConcept or
> EnumerableRangeConcept or IteratorRangeConcept?
Why invent a new concept? This is an Iterator that is ConvertibleToBool.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk