Boost logo

Boost :

From: Haim Cohen (haim.cohen_at_[hidden])
Date: 2004-06-01 03:47:33

Sorry if this is a repost - I am almost sure my last post did not reached out.

Rob Stewart wrote:

> meaning "arbitrary value." However, "indeterminate" leaves no
> doubt as to the meaning of the value and doesn't depend upon
> one's experience with electronics. Another possibility would be

I agree. Although I see the highest potential of the library in EDA applications, the
meaning of the value should not depend on any problem domain - like electronics.
I guess I was little bit biased here by my problem domain.

> As I've already rejected the "x" notion, that leaves
> "unknown_bool" or, by extension, "indeterminate_bool." While
> these names suggest that there is an unknown or indeterminate
> Boolean value, they don't suggest to me a type that includes
> true, false, *and* unknown/indeterminate. "tribool," OTOH,

I disagree. IMHO, The name unknown_bool hints that in addition to the 2 traditional
values of bool, there is also an unknown bool.
I am not a native user of the English language, but this is what the name unknown_bool
hints *me*.


Haim Cohen
Software Engineer
haim.cohen_at_[hidden] / haimcohen2002_at_[hidden]
Analog Devices

Boost list run by bdawes at, gregod at, cpdaniel at, john at