Boost logo

Boost :

From: Joaquín Mª López Muñoz (joaquin_at_[hidden])
Date: 2004-06-02 12:42:57

Hi Rob,

Rob Geiman ha escrito:

> Joaquín Mª López Muñoz wrote:
> >Hi all,
> >
> >As requested by some at the mailing list, I've migrated allocator.hpp
> >from boost/multi_index/detail/ to boost/detail/ (with some obvious
> >namespace changes.)
> >
> >
> I'd like to request a name change from allocator.hpp to something else
> more appropriate (ie, allocator_helper.hpp). Correct me if I'm wrong,
> but I believe this isn't an actual boost allocator implementation, but
> rather helper classes to get passed rebind issues in some STL
> implementations.
> The reason I mention this is that I was actually thinking of creating a
> boost::allocator class to work with RAII classes. That is, an allocator
> class that allows you to pass constructor parameters when constructing
> the object.

Yes, you're right in that allocator.hpp does not implement any standalone
Although I don't think this would clash with a future boost::allocator (the stuff
is in boost::detail::allocator), I don't have any problem with renaming to
allocator_helper (it's a better name, actually.) If no one else objects (which
I doubt) I'll apply the name change tomorrow.


Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at