Boost logo

Boost :

From: Joaquin M Lopez Munoz (joaquin_at_[hidden])
Date: 2004-06-03 03:03:49

David Abrahams <dave <at>> writes:

> >> I think allocator_rebind would be a much better name than
> >> allocator_helper.
> >>
> >
> > Ummm, the problem with allocator_rebind is that the header
> > contains some other stuff not strictly related to rebinding:
> >
> > * partial_std_allocator_wrapper
> > * construct (allocator-independent construction function)
> > * destroy (allocator-independent destruction function)
> Those latter two aren't really allocator helpers, are they?
> I don't know what the first one is, but maybe this should be 3
> separate headers.

Thre three together form some kind of nanolibrary to ease
allocator handling. construct and destroy are convenient
substitutes for the corresponding allocator memfuns, as they
can help eliminate unnecessary dependencies from the allocator

I could detach construct() and destruct() from the header,
but partial_std_allocator_wrapper is used in the rebinding

For these reasons, I think allocator_rebind is not an
appropriate name. Anyone suggesting a better name than
allocator_helper? (Andreas? you wanted to use this stuff)

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at