Boost logo

Boost :

From: Alex Chovanec (achovane_at_[hidden])
Date: 2004-08-06 10:30:53

Believe it or not, deferred_iterator was the other name that I was
considering, but now I see that it's already in the library as


"Rob Stewart" <stewart_at_[hidden]> wrote in message
> From: "Alex Chovanec" <achovane_at_[hidden]>
> >
> > When you dereference an instance of the adapted iterator type Iter, you
> > a const reference to its base iterator of type Base. So instead of
> > delegating the dereference operation to its base and returning the
> > the iterator adaptor simply returns its base. Since it doesn't
> > its base, I would probably name it "lazy_iterator", or something like
> The idea is intriguing, but the iterator isn't lazy, it just
> doesn't dereference ("lazy" suggests that it will do the work on
> demand, not immediately). A better name would be
> "deferred_iterator" or "iterator_iterator."
> --
> Rob Stewart stewart_at_[hidden]
> Software Engineer
> Susquehanna International Group, LLP using std::disclaimer;
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at