Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-08-16 05:34:27

"Jonathan Turkanis" <technews_at_[hidden]> wrote in message news:cfpjrh$f65$

| I don't like dropping the '_type' here -- One of the main advantages
| of a naming convention is that you can figure out what the name should
| be without consulting the docs. Consider a nearly identical situation
| in my iostreams library (to be reviwed later this month). Instead of
| typename Source::char_type
| I use
| boost::io::char_type<Source>::type
| If we were to drop the '_type' we would have boost::io::char, which is
| illegal. Same for int_type. Of course, the convention could be to keep
| '_type' if necessary, or to use a trailing underscore, but I'd rather
| have the easy-to-remember convention that the metafunction has the
| same name as the traditional nested type.

you could also say


and put it in namespace boost?

| > The smallest change is not to change the iterator library and
| therefore I will
| > use the prefix range_ for my metafunctions unless there are heavy
| objections.
| I think range_xxx and ranges::xxx are about equally good. I don't
| really like the convention of forming namespace names by adding 's' --
| although I don't have a better idea -- so perhaps I'd choose
| range_xxx.




Boost list run by bdawes at, gregod at, cpdaniel at, john at