From: Jonathan Turkanis (technews_at_[hidden])
Date: 2004-08-18 18:14:53
"Bronek Kozicki" <brok_at_[hidden]> wrote in message
> Daniel James wrote:
> > boost::resolve<>::cast(&C::g);
> > boost::resolve<int>::cast(&C::g);
> > But maybe that's a bit too jumbled up.
> Personally I think that it's nice and simple :)
I like it too, now. I think trying to see it as a casting operation
made it look inelegent. How about a simple name change:
For overload resolution by arity one could write:
boost::overload< by_arity<3> >::resolve(&C::g)
but that's still a bit cumbersome.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk