Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-08-31 11:57:56

From: Daryle Walker <darylew_at_[hidden]>
> On 8/27/04 6:43 PM, "Jonathan Turkanis" <technews_at_[hidden]> wrote:
> > "Rob Stewart" <stewart_at_[hidden]> wrote in message:
> >>
> >> I don't think many would have a hard time recognizing the
> >> parallel between "newl" and "endl." If you rename it to
> >> "newline," there's no chance of misunderstanding the manipulator,
> >> right?
> I know "new_line" or "newline" would be clearer, but "newl" happens to be
> the same length as typing in ['\n'] or ["\n"], four characters. If I change
> "skipl" to "skip_line", I should do the same to "newl" to be consistent.

"newline" is easier to type than "\n" or '\n' so the comparative
length isn't really an issue.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at