Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-09-07 12:02:47

From: John Torjo <john.lists_at_[hidden]>
> > Yes. Thanks. The current name is 'filtering_streambuf'; in the past I've used
> > 'filtered_streambuf' and 'filter_streambuf'. What's your preference?
> >
> filtering_streambuf is better

It isn't the streambuf that's doing the filtering; it's the
filters pushed onto it. Therefore, I think it should be
"filtered_streambuf" or "filterable_streambuf."

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at