Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-09-15 10:09:30

Dear All,

In the pre-redmond mailing Walter Brown discusses the possibility of adding
these members to standard container classes:

const_iterator cbegin();
const_iterator cend();
const_reverse_iterator crbegin();
const_reverse_iterator crbegin();

The motiviation is that we want to be able to say explicitly "give me a const
iterator" without doing ugly casts.
IMO a sound idea.

Given the framework in boost.range these would be absolutely *trivial* to add.

1st vote: for or against adding these?

2nd vote: which naming scheme to use:

 a: cbegin(), cr_begin()

 b: const_begin(); const_rbegin();

The motivation for chosing the latter could be that "cr" contracttions become
harder to read.

Let me know what ya think.

best regards


Boost list run by bdawes at, gregod at, cpdaniel at, john at