Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-09-17 08:05:35

"David B. Held" <dheld_at_[hidden]> writes:

> Andreas Huber wrote:
>> [...]
>> Plus, Dave's convention has the advantage that only very few people
>> need to change the names in the docs/books, etc. Personally, I would
>> have preferred boost::fsm a lot over Boost.FSM but it's not *that*
>> important, is it?
> The convention I use is that when talking about the entire library, go
> with Boost.LibraryName, and when talking about a specific component,
> use boost::component_name. That's because there's times when I want to
> talk about boost::bind() in particular, disregarding the other elements
> in the Boost.Bind library, and Boost libraries often contain a type that
> has the same name as the library, but also other types that one might
> want to talk about individually.

I take the latter for granted. It wouldn't make any sense to refer to
Boost.Bind when you really meant boost::bind.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at