Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-09-20 10:46:07

Richard Hadsell <hadsell_at_[hidden]> writes:

> Jonathan Turkanis wrote:
>>When I was writing it I initially typed 'const_cast', but then thought to
>>myself: why use my big guns if I don't have to? ;-)
> For clarity -- to tell the reader that you intended to modify the
> const-ness.

static_cast is a bigger gun than const_cast. At least const_cast
cant violate data layout, and unless there is actually a constant
object, won't result in undefined behavior.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at