From: Cromwell Enage (sponage_at_[hidden])
Date: 2004-11-17 22:39:23
--- David Abrahams <dave_at_[hidden]> wrote:
> Cromwell Enage <sponage_at_[hidden]> writes:
> > Since they may be used so often, should they be
> > defined in a single library-specific header,
> > e.g. <boost/graph/keywords.hpp>?
> Not neccessarily. They should probably be decoupled
> and included as needed in each header.
> > And would it help if each name had an appropriate
> > prefix, like "bgl_", to help avoid object
> > collisions?
> Not much; I would nest the unnamed namespace inside
> boost (or a sub-namespace thereof).
Okay, I'll try to organize my code accordingly.
> > I find operator| to be the most logical operator
> > for assigning defaults, more so than operator& or
> > operator=.
> I'm not positively sure what you're saying here.
> Our design does use operator| for "providing"
> defaults. They're never "assigned." To do that,
> you would (tautologically) have to use operator=.
Bad wording on my part.
> > The resolution of the design issue concerning
> > parameter-dependent defaults bears more weight on
> > my vote than any of the other pluses or minuses
> > I've mentioned so far. If it can be resolved
> > easily, then I vote yes. Otherwise, not until it
> > is resolved.
> I'm positive we can do something about it without
> too much trouble.
Very well. You have my accept vote!
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk