Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2004-12-02 00:17:40

Joel de Guzman wrote:

> I've been wanting to ask this before: Shouldn't this be spelled:

Sure, if that's what people prefer. It's only BOOST_FOREACH because it
is approximating the "foreach" keyword that some languages have, which
might serve to emphasize that it works like a new keyword and not like
an STL algorithm. It's also one less character. But those are both
exceedingly lame reasons. I don't care either way.

Eric Niebler
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at