Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-02-11 20:29:56

"Hartmut Kaiser" <HartmutKaiser_at_[hidden]> writes:

> Transform_iterator _is_ part of boost already, the difference is, that wave
> uses a slightly different version (for performance reasons the version
> contained in Wave returns the transformed value by reference - I don't know,
> whether this is commonly possible - in Wave it is used to flatten a parse
> tree). That's the reason, why it is named ref_transform_iterator.

The boost::transform_iterator also returns by reference, if you set it
up right. No need for code duplication.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at