Boost logo

Boost :

From: Caleb Epstein (caleb.epstein_at_[hidden])
Date: 2005-02-11 21:56:14


On Fri, 11 Feb 2005 17:55:26 -0500, christopher diggins
<cdiggins_at_[hidden]> wrote:

> > * There should be a public elapsed() method to extract the elapsed
> > time from a profiler. Perhaps it should just be public?
>
> Yes.

Actually, elapsed() should be a method and should return elapsed +
t.elapsed(). It will need to have a name other than "elapsed" though
or you'll need to change the name of the member (I'd recommend the
latter).

> > * The basic_profiler ctor initializes members in a different order
> > than they are declared in the class
>
> Does that matter?

Not really, but gcc -Wall warns about it. Its worth fixing if only for that.

-- 
Caleb Epstein
caleb dot epstein at gmail dot com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk