Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-02-13 22:00:53

Jason Hise wrote:
> In my code, I use the term allocator for policies that mirror the Loki
> singleton creator policies. For example, my dynamic_allocator class
> maps almost directly to Alexandrescu's CreateUsingNew policy. It has
> been suggested that allocator is a misleading term, because users will
> think that such classes were meant to work with the allocator policy
> used in the standard containers. Is the term allocator really that
> misleading? Should I make the massive change in my code to refer to
> these classes as creators?

I doesn't make that much difference, because whatever you decide, it will be
discussed again ad nauseam during review ;-)

However, I think using 'allocator' is a bit misleading. Also, it shouldn't be
hard to make the substitution in your code.


Boost list run by bdawes at, gregod at, cpdaniel at, john at