Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-03-08 11:47:36

Caleb Epstein wrote:
> On Mon, 7 Mar 2005 20:29:17 -0700, Jonathan Turkanis
> <technews_at_[hidden]> > Here are the names I've thought of:
>> good: good, is_good
>> eof: eof, is_eof
>> fail: fail, eagain, is_eagain, would_block, should_retry
> I like "good" and "eof" as they are familiar from "native" iostreams
> and seem to map well to the asynchronous case. I think fail is
> perhaps too strong in this context however, and eagain is too
> "unix-y". My preference for this property would be "would_block".

Thanks for your feedback. would_block is unix-y too, no?


Boost list run by bdawes at, gregod at, cpdaniel at, john at