Boost logo

Boost :

From: Dave Harris (brangdon_at_[hidden])
Date: 2005-03-22 12:31:16

In-Reply-To: <007b01c52ede$3ceefd80$6501a8c0_at_pdimov2>
pdimov_at_[hidden] (Peter Dimov) wrote (abridged):
> So, in my opinion, your original suggestion is still the best one, even
> though I did not seem to agree at first. ;-)


> > If not, then maybe we should have a hash_combine that just combines
> > hashes. At the moment the combining is mixed in with the getting;
> > it's not a very orthogonal API.
> ... yes, hash_value( size_t ) is the identity function partly for this
> reason.


(And this is another argument for adding the non-zero fix in hash_combine
rather than hash_value.)

-- Dave Harris, Nottingham, UK

Boost list run by bdawes at, gregod at, cpdaniel at, john at