From: Eric Niebler (eric_at_[hidden])
Date: 2005-03-23 19:13:44
Thorsten Ottosen wrote:
> "Eric Niebler" <eric_at_[hidden]> wrote in message
> | But we can still come up with a convention used by any *new* ADL
> | customization points. That's what you're asking about anyway, right?
> yes, agreed.
> | >
> | > Free-standing functions seems to have slightly different
> | > goals.
> | You lost me. What goals?
> that boost:::foo() does ADL.
> new_clone() is used primarily inside the
> containers and does therefore not suffer much
I'm still lost. What inconvenience?
> | > One consequence of using the name
> | > boost_range_begin() is that the users code won't
> | > work with the next standard library. I would like to retain
> | > compatibility if possible.
> | >
> | First, there's just no reasonable expectation that boost libraries
> | should be forward-compatible with some future version that gets accepted
> | into the standard. Libraries change as they go through standardization
> | -- that's expected. And second, the standardization committee might
> | reason like I did and decide that "std_range_begin()" is a better name
> | than "range_adl_begin()", and you've lost compatibility anyway.
> true, that could happen. the difference being that we might not.
> In some sense it also seems wierd that the same customization point
> should have different points in different libararies. Seems redundant.
What is redundant? What different libraries? We're talking about the ADL
customization points of /one particular library/. A customization point
cannot be in two libraries simultaneously. I must have missed your point
again. Please set me straight.
> Another set of names could be
But you still haven't given me a reason I can understand why it
shouldn't be "boost_range_begin()" etc..
-- Eric Niebler Boost Consulting www.boost-consulting.com