Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-03-23 20:50:49


"Thorsten Ottosen" <nesotto_at_[hidden]> writes:

> Dear all,
>
> I'm going to change the ADL lookup hook of range functions.
>
> instead of the irritating
>
> void foo()
> {
> using namespace boost;
> begin(r);
> }
>
> we simply now say
>
> void foo()
> {
> boost::begin(r);
> }
>
> and get full ADL lookup. This changes the extension protocol
> to overiding these three functions:
>
> range_adl_begin()
> range_adl_end()
> range_adl_size()
>
> Any comments before I commit?

Yes. I think you should get rid of "ADL" in the name. It doesn't add
enough and is easy to misinterpret.

-- 
Dave Abrahams
Boost Consulting
www.boost-consulting.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk