Boost logo

Boost :

From: Thomas Witt (witt_at_[hidden])
Date: 2005-03-24 20:52:58


David Abrahams wrote:
> Thomas Witt <witt_at_[hidden]> writes:
>>For the record I don't think it's irritating at all. It very clearly
>>states what is going on. I can see it being cumbersome though.
> Cumbersomeness is irritating ;-)

You are missing my point ;-)

> The user can always call the hook unqualified. That's _going_ to be a
> public part of the library's interface.

Well, if you look at it this way then the _only_ functionality
boost::begin provides is a syntactic shortcut. I.e.



using boost::range_begin;

are functionally equivalent.

Did I miss something?

In this case we have the real name in the helper and some artificially
uglified name in all class interfaces. This doesn't feel right to me.

You could also argue that boost::begin's name does not really describe
what it's doing. Having a namespace qualified call disguise an
unqualified call is another issue that gives me headaches.


Thomas Witt

Boost list run by bdawes at, gregod at, cpdaniel at, john at