Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-05-02 19:37:33

I was just looking at using Boost.Range in my new Sequence library and
noticed the following:

  1. The documentation of requirements uses names like range_iterator
     without qualification. You need to add the boost:: prefix or
     make it very clear that all names are implicitly boost:: prefixed
     (as opposed to, say, boost::range:: prefixed). I prefer the
     former; people may land on the documentation for reference
     without reading all the introductory material.

  2. Names like range_iterator in the requirements tables should be
     hyperlinked to some documentation for them.

  3. The documentation you land on should clearly state in which
     header those names can be found.

  4. Having a pile of names prefixed by "range_" (like
     boost::range_const_iterator) just seems wrong to me when we have
     namespaces. Is there a good reason we're not using
     boost::range::const_iterator or boost::ranges::const_iterator?

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at