Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-05-02 23:51:40

"Jonathan Turkanis" <technews_at_[hidden]> writes:

> David Abrahams wrote:
>> I was just looking at using Boost.Range in my new Sequence library and
>> noticed the following:
>> 4. Having a pile of names prefixed by "range_" (like
>> boost::range_const_iterator) just seems wrong to me when we have
>> namespaces. Is there a good reason we're not using
>> boost::range::const_iterator or boost::ranges::const_iterator?
> I think I'm partially responsible for this. Originally Thorsten was
> using the names value_type_of, difference_of, iterator_of, etc, and
> I pointed out that the iterator library uses the names iterator_xxx
> for similar metafunctions. I believe there was extensive discussion
> about it at the time.

Two wrongs don't make a right! Mea culpa; I should have put those in

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at