Boost logo

Boost :

From: Jonathan Turkanis (technews_at_[hidden])
Date: 2005-05-03 13:57:05


Thorsten Ottosen wrote:
> "Jonathan Turkanis" <technews_at_[hidden]> wrote in message
> news:d58c5t$lbl$1_at_sea.gmane.org...
>> Thorsten Ottosen wrote:
>>
>>> well, you can't call it io::char :-)
>>
>> Yeah, I know. Since char_<> would be an abomination, the alternative
>> is char_type. I've got the same problem with int_type.
>
> one could of course say
>
> io::character
> io::integer

Not bad! Thanks.

I wonder if the nested type should be called character as well. I've taken it
for granted that I should use the standard library convention, but maybe that's
not so important:

     struct my_filter {
         typedef char character;
         typedef input_filter_tag category;
         ...
     };

Jonathan


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk