Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2005-05-03 17:23:49

"David Abrahams" <dave_at_[hidden]> wrote in message
| I don't understand why there are so many implementations of the
| range_value metafunction. It seems to me that it should always be
| defined to be:
| template <class R>
| struct range_value
| : boost::iterator_value<
| typename range_iterator<R>::type
| >::type
| {};
| What am I missing?


do we dare change it before a release?


Boost list run by bdawes at, gregod at, cpdaniel at, john at