Boost logo

Boost :

From: Jonathan Wakely (cow_at_[hidden])
Date: 2005-05-09 03:04:50

On Sun, May 08, 2005 at 10:49:32PM -0500, Rene Rivera wrote:

> Jonathan Wakely wrote:
> >On Sun, May 08, 2005 at 12:46:10PM -0500, Rene Rivera wrote:
> >
> >>For this sole failure on the tests that I run:
> >>
> >>
> >>
> >>I did some investigation and narrowed the problem down to this:
> >
> >[snip testcase]
> >
> >>Which gives a link error of:
> >>
> >>undefined reference to `std::basic_iostream<char,
> >>std::char_traits<char> >::~basic_iostream()'
> >>
> >>And AFAICT that particular dtor is not in libstdc++. And for that matter
> >>the entire std::basic_iostream<char,..> instance is missing.
> >
> >I've had very similar problems with that dtor missing from libstdc++,
> >see
> >(despite the subject line, this was nothing to do with PR16715, that
> >just made a latent problem apparent)
> That doesn't seem to have any resolutions to it. Did I miss something?
> What was the resolution?

No, I was never able to figure out what was going on and the problem
went away eventually. I wasn't sure it wasn't something I'd done wrong
on my system, it worked fine for everyone else, so didn't file a bug
report. Now that I think about it, the problem *might* have disappeared
when I upgraded from Fedora Core 1 to 2, so an upgraded binutils might
have fixed it.

> >Could you check whether the wchar_t specialisation is in the
> > library?
> >
> >nm --demangle | grep 'basic_iostream<wchar_t'
> Had already done that.. which is why I said the char specializations
> where absent. The wchar_t ones are present.

> >Both the char and wchar_t specialisations should be in the lib, thanks
> >to explicit instantiation in istream.tcc
> Not in my case :-(

That must be the exact same issue as I had.

> >This problem eventually went away IIRC, I was tracking the CVS version
> >and stopped having the problem at some point.
> Well it doesn't help me :-( As this is the straight release tar archive.
> And as was pointed out on another post, it's only my problem. Others
> have those symbols with the 3.4.3 release.

I suggest filing a PR in bugzilla, giving the full configure command
used to build the compiler and giving the URL to the thread I started on
the subject. I'll add what I can to it, including that upgrading
binutils might have been what solved it.

If you have a compiler exhibiting the problem at the moment you'll be
able to give more details than me, as I no longer have the problem.


Bullshit makes the flowers grow & that's beautiful

Boost list run by bdawes at, gregod at, cpdaniel at, john at