Boost logo

Boost :

From: Brian Braatz (brianb_at_[hidden])
Date: 2005-06-09 15:05:40

Looks interesting. I wasn't able to find the performance tests though.

Also- I wonder if a better name might be found. maybe simply
"associative_vector"- but that is a lot of typing.


or maybe come up with a name for the body of libraries (containters)
that you intend to implement.

something like



(quick check on for the word "speed"):

Main Entry: speed
Part of Speech: noun
Definition: rate
Synonyms: acceleration, activity, agility, alacrity, breeze,
briskness, celerity, clip, dispatch, eagerness, expedition, fleetness,
gait, haste, headway, hurry, hustle, legerity, lick, liveliness,
momentum, pace, precipitancy, precipitation, promptitude, promptness,
quickness, rapidity, rapidness, readiness, rush, rustle, snap, steam,
swiftness, ton, urgency, velocity

hmmm... none of that is working very well

one other suggestion:


(i.e. for optimized)

I hope that helps or sparks an idea.


> -----Original Message-----
> From: boost-bounces_at_[hidden]
> On Behalf Of Mikhail Glushenkov
> Sent: Wednesday, June 08, 2005 3:26 PM
> To: boost_at_[hidden]
> Subject: [boost] [ann]Fast_lookup - first snapshot available
> First snapshot of the to-be proposed Fast_lookup library is available
> for download at the vault.
> Direct link (watch for line breaks!):
> &directory=fast_lookup
> Sorry, no documentation as of yet.
> Fast_lookup provides "sorted vector"-based versions of standard
> associative
> containers, thus embracing the common practice.
> Highlights of this release:
> * map and set have been implemented
> * Two different storage policies - 'default' and KeepKeysSeparate,
> is
> usually faster, but takes more memory
> * Out-of-the-box support for Boost.Serialization
> I haven't done any significant optimizations yet, but the performance
> tests are
> in, and they show that we are in pretty good shape(compared to
> Loki::AssocVector).
> Fast_lookup currently does not work on vc6 though I've made some
> stabs
> at this problem.
> Since I'm going on vacation starting from this Friday, the next
> will
> likely be posted in August. Planned features include multiset and
> +
> indirect storage(some parts of pointer_containers library will be
> reused)
> Any suggestions, comments, feature requests or critique are welcome.
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at