Boost logo

Boost :

From: BRIDGES Dick (Dick.Bridges_at_[hidden])
Date: 2005-06-17 19:04:41

[Please ignore exemplar in previous missive. I can't seem to cancel

Apologies in advance if this belongs on the boost-users_at_[hidden]
list. After my posting vast quantities of [probably worthless] example
output on jamboost_at_[hidden], Vladimir Prus provided [I added the
-Is] this example and suggested I post it here where the Boost.config
maintainers might be able to help.

OS is Fedora3 on x86. We have empirically confirmed the cross-compiler
being used supports pthreads. ALL the rest of the boost libs compiled
successfully (with only the occasional warning). I'm only 13 targets
from home.

<exemplar apologies=worthless-line-wrapping>
Program file test.cpp contains only the following line:
#include <boost/thread/condition.hpp>

 [root_at_mycomputer boost_1_32_0]#
ftfloat-linux-gnu-c++" \
-I/usr/local/boost_1_32_0 \
++/3.3.3/ \
++/3.3.3/arm-softfloat-linux-gnu/bits/ \
-pthread test.cpp
In file included from
                 from test.cpp:1:
/usr/local/boost_1_32_0/boost/config/requires_threads.hpp:47:5: #error
"Compiler threading support is not turned on. Please set the correct
command line options for threading: -pthread (Linux), -pthreads
(Solaris) or -mthreads (Mingw32)"
[root_at_mycomputer boost_1_32_0]#

I tried working my way through the config headers and got TOTALLY lost.
I tried -H, -E and #warning before I gave up and submitted this missive.
Even if you can provide the answer "off the top of your head", would you
mind providing a pointer or two toward the correct path to finding the
problem? I'd appreciate that at least as much as the solution itself.

Sincere thanks in advance,
Dick Bridges
"For every complex problem, there is a solution that is simple, neat,
and wrong." H.L. Mencken

Boost list run by bdawes at, gregod at, cpdaniel at, john at