From: David Abrahams (dave_at_[hidden])
Date: 2005-06-23 09:19:56
"Thorsten Ottosen" <nesotto_at_[hidden]> writes:
> "David Abrahams" <dave_at_[hidden]> wrote in message
> | "Thorsten Ottosen" <nesotto_at_[hidden]> writes:
> | > yeah, seems bad. I don't understand how you would define
> | > std::iterator::value<T>::type etc then?
> | You wouldn't. That doesn't work.
> ok, then maybe it is better to stick with
> range_iterator etc.
Naah. If and when these things go into std, they should be in a
sub-namespace, std::range, since otherwise some of your names will
probably conflict with an updated standard iterator facility. Also,
Boost never contain an interface we know to be suboptimal based on
speculation about how a standard version of it might look someday.
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk