Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-06-27 15:12:35

Cromwell Enage <sponage_at_[hidden]> writes:

> I've been browsing the reference.rst file in the CVS
> tree.
> Is there a difference between "Keyword Tuple" and
> "Argument Tuple"? If not, then I believe "Argument
> Map" be a better name, since some of the expression
> semantics (and their runtime complexities) are similar
> to those of a map. Accordingly, I would change "Index
> Expression" to "Keyword Expression" and "Index Default
> Expression" to "Keyword Default Expression". A person
> reading "Index Expression" for the first time might
> think it was a specialized "Integral Constant
> Expression".
> Let me know if I'm missing anything.

Only that we're re-doing the documentation, possibly from the ground
up, this week ;-)

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at